Back to overview
Resolved

Scheduled Router Core Maintenance

Jun 14, 2026 at 12:00am UTC  –  Jun 14, 2026 at 12:05am UTC
Affected services
Performance Node 1
Performance Node 2
Performance Node 3
Standard Node 1
Economy Node 1

Resolved
Jun 14, 2026 at 12:05am UTC

Maintenance ended

Created
Jun 14, 2026 at 12:00am UTC

We would like to inform you that a planned maintenance window will be performed on our Router Core due to issues observed over the past few days.